Вакансии для программистов 1С. Компания Intercomp.
Обмен опытом по 1С Работа для программистов 1С Общение и отдых
Проекты Программы Статьи Ответы Удаленная работа Вакансии Программисты Конкурсы Блоги Форум
Добро пожаловать! Кто вы?
Программист 1С
Бухгалтер
Кадровая служба
Начальник IT
Нажмите на свою профессию, если хотите быстрее сориентироваться на сайте

Каталог меток

План обмена
Как сделать отбор в наборе записей регистра накопления, чтобы не передавались не нужные записи? регистр передается с ссылками на объекты которых нет в подчиненной базе.

Источник: http://www.forum.mista.ru/topic.php?id=274347
Волшебный форум (mista) 25.05.07 (00:00)
Запрос
Программа 1С coder1cv8 25.05.07 (00:00)
Берешь и делаешь... В чем сложность? Вот пример отбора по Организации:
Если Метаданные.РегистрыНакопления.Содержит(ОбъектМетаданных) Тогда
   Регистратор=ЭлементДанных.Отбор.Регистратор.Значение;
   Если ЕстьРеквизитДокумента("Организация",Регистратор.Метаданные()) Тогда
       Если глТекущийУзел.БазаДанных.ЮрЛица.Найти(Регистратор.Организация,"Организация")=Неопределено Тогда
           ОтправкаЭлемента=ОтправкаЭлементаДанных.Игнорировать;    
       КонецЕсли;
   
   КонецЕсли;
КонецЕсли;
Показано с 1 по 1 из 1 ответов.

Страницы:

1

aitika.ru © 2009-2010


Посетителей онлайн: 8
Пользователи:


Новые публикации (rss):
Добавить в Google Reader
Читать в Яндекс.Ленте